Table of contents

PHP 7.4 configure error Package requirements (libcurl >= 7.15.5) were not met

PHP May 24, 2020 Viewed 2.2K Comments 0

Question

When compiling php-7.4.6 on Linux, run the command ./configure --prefix=/opt/php-7.4.6 --with-pdo-mysql --enable-fpm --with-curl, but the following error occurs.

checking for libcurl >= 7.15.5... no
configure: error: Package requirements (libcurl >= 7.15.5) were not met:

Package 'libcurl', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CURL_CFLAGS
and CURL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Solution

It requires libcurl-devel package.

1. Install manually

On the web page https://pkgs.org/search/?q=libcurl, find the libcurl-devel version that matches your operating system, and download and install it.

2. With command line

Ubuntu / Debian

sudo apt-get install libcurl4-openssl-dev

RHEL / CentOS

sudo yum install libcurl-devel
Updated Jul 01, 2020